Совместимость приложений c Apple iOS

iOS_sovmestimСовместимость приложений между телефоном iPhone (плеером iPod touch) и планшетом iPad мы рассматривали в статье про универсальные приложения. Но помимо универсальности существует еще один, немало важный, фактор, влияющий на то, установится приложение в устройство или не установится – совместимость с версией прошивки Apple iOS.

То есть, подойдет приложение или не подойдет к Вашему устройству зависит от версии прошивки iOS, установленной в Apple iPhone, iPod touch или iPad’е.

В качестве примера рассмотрим следующую ситуацию: имея на руках первую модель iPhone (2G) с версией прошивки – 3.1.2, мы решили установить бесплатную программу ICQ Messenger прямо из приложения App Store, т.е. с самого телефона. Для тех, кто не знает, как ставятся игры и программы, читаем про установку приложений в iPhone. Но после нажатия кнопки – Установить, iPhone вывел на экран уведомление (которое можно увидеть на изображении выше) следующего плана: «Требуется обновление. Для этого приложения требуется iOS 4.0.»

Получается, что версия прошивки нашего телефона не подходит для установки мобильного клиента ICQ Messenger, соответственно установить эту программу мы сможем лишь в устройство с прошивкой 4.0 и выше.

sovmestimost
Для того чтобы предварительно узнать совместимо ли приложение с версией прошивки iOS, установленной в Вашем телефоне или планшете, нужно посмотреть требования к приложению. Узнать требования к любой программе или игре можно тремя способами, первый способ мы уже рассматривали выше, когда при установке появляется уведомление и показывает необходимую версию прошивки. Узнать требования к приложению можно при помощи программы iTunes, находим свое приложение в iTunes Store, заходим в него и смотрим графу «Требования», где в нашем случае указанно «Требуется iOS 4.0 или более поздняя версия.»

Ya_Search
Так же требования к приложению можно посмотреть в App Store при помощи любого Web-браузера, для этого обычно делаем так: запускаем браузер, открываем любой поисковик, к примеру Google или Yandex, в строке поиска вводим «Название приложения App Store», после чего смотрим требования, выбранного в результатах поиска приложения.

После того как с требованиями к игре или программе разобрались, нужно посмотреть версию прошивки своего гаджета, если не знаете как это делается, читаем – как узнать версию прошивки iPhone. Если версия прошивки iOS Apple-устройства соответствует требованиям устанавливаемого приложения, то такая игра или программа должна подойти для Вашего iPhone, iPad или iPod touch.

Запись опубликована в рубрике СЕКРЕТЫ с метками . Добавьте в закладки постоянную ссылку.

38 комментариев:

  1. Доброго времени суток! Существует ли способ обойти проверку на версию iOS? Имею сл. проблему – на iPhone 3G установлена версия 4.1.2, хочу установить приложение Skype, но в AppStore получаю сообщение – «Для этого приложения требуется iOS 4.2″ Есть ли возможность установить старую версию программу (предыдущую), так как скайп отлично работал на 4.1.2

    • Привет, к сожалению разработчики приложения Skype не адаптировали новую версию под первые модели iPhone. Соответственно на iPhone (2G) и iPhone 3G не возможно поставить Скайп официально (с App Store)

  2. Оксана

    Ренат, добрый день!У меня такая проблема не с icq, а с facebook – неужели нет никакого способа его установить на прошивку 4.2.1???

    • На сегодняшний день для установки приложения Facebook нужна прошивка версии 4.3 и выше. В качестве альтернативы можно использовать любой мобильный клиент с поддержкой протокола Facebook к примеру – IM+

  3. Оксана

    Ренат, у вас просто отличный сайт и консультации – спасибо Вам ОГРОМНОЕ от всех чайников и не очень!:)

  4. Не могу установить whatsapp требует 4.3 у меня 4.2.1 есть способ решить эту проблему????плиииизз очь нужно
    Или альтернатива

    • Как вариант – обновить прошивку, альтернатива – Viber

  5. У меня 3G, это последняя

  6. Viber тоже требует 4.3

  7. Нуууууу$ мне бы на этот

    • Пользователи iPhone 3G и моделей ниже, пока не поздно, ставьте ICQ или QIP

  8. А можно с этим icq общаться с теми кто в whatsapp ???

  9. Здравствуйте, подскажите пожалусто, скачиваю программу или игру на 5 iPhone через интернет на комп, потом пытаюсь установить через iTunes, синхранизирую, начинается установка в iPhone не заканчивается и пишет что синхронизация не возможна и не устонавливает программу или игру, что делать. заранее спс!

  10. Хочу купить Apple iPhone 4 32Gb и установить Viber & Skype. Для них нужен ios 4.3. Подходит для этого данная модель телефона(там просто пишут ios 4)?Спасибо.

  11. Катеринка

    Ренат доброе время суток. Подскажите пжл в мя Appele iPhone 4 версия 4.3.1(8G4) пришло обновления скайпа-пытаюсь обновить, но выходить табличка ТРЕБУЕТСЯ iso 5. А так же при установке многих программ появляется данная надпись ;( Помогите мне, подскажите как ме как решить эт как надо поменять эт прошивку ;( ( если че ни так написала-назвала прошу зарание прощения – чайник в данном вопросе)

  12. Андрей

    У меня iphone 3gs. Хочу поставить на него прогу через itunes,а он пишет: программа не была установлена на iphone так как она несовместима с этим ipone. Что в этой ситуации можно предпринять?

  13. Андрей

    хотя в itunes пишет что программа совместима с iphone 3gs.

  14. Сергей

    Ясное же дело, что при установке девайс сканирует определенный код в приложении, после сканирование он либо закачует, либо нет, но было бы не плохо найти папку с кодом и научиться его редактировать, у меня по сей день не получаеться это сделать, даже при отображении скрытых файлов..
    Конечно логичнее «типа изменить» код в самой ios, нежели с приложениями мучаться..
    Вот только блин я все-же не знаю как это сделать..
    Открыть ipa файл легче простого, если кто не знает (iTools, 7-zip архиватор)
    Кто нибудь имеет понятия, о чем я говорю?
    Если кто нибудь пробывал это делать, или шарит в этом деле, пишите на почту может вместе разберемся.. У меня ios 4.2 и я запарился на нее искать то что нужно, я уже молчу о ios 8-й, мне хотя бы на 5-ю перейти (приложения для этих версий)…

  15. Ксения

    Здравствуйте, помогите пожалуйста! У меня айфон 3 с iOS 6.0. Не получается установить с App Store приложение, пишет что надо iOS 7.0. Хотя в интернете писали что можно установить предыдущую версию приложения. Подскажите, пожалуйста, что делать??

    • Ксения, Apple вроде планировали размещение старых версий приложений для старых моделей устройств, пробуйте установить с AppStore. В интернете наверно имели ввиду телефон с джейлом, хотя если старая версия приложения когда-то ранее вами ставилась (т.е. подписана вашим Apple ID), а теперь этот файл IPA был найден среди файлов в компе (к примеру), то установить его можно без джейла (официально).

  16. Никита

    У меня следующая проблема. Я хочу скачать игру (Приложение) – игра (afterpulse) на iPad’e 4 я нажимаю загрузить у меня пишет: (невозможно загрузить), а снизу – Приложение не совместимо с вашим устройством. Единственный вопрос: почему? Пожалуйста решите этот вопрос.

    • Никита, iPad 3, 4 и iPhone 5 с Afterpulse не совместимы видимо нужен процессор A7 или A8, поддерживающие новый API Metal, необходимы для этой игры

  17. Не могу скачать аську на ios 7, пишет что нужна 8, нельзя как то обойтись и скачать ее на 7?

    • Почему не кончаются игры и Приложение на последний версии iOS она грузится, но не устанавливается.

  18. Руслан

    Добрый день. Подскажите пожалуйста вот у меня есть ipod touch 4 у него стоит версия 6.1 я могу его обновить до 7 или 8 ios? Если не получиться то подскажите ещё есть ли какая та программа типа appstore ток чтобы старые игры я скачивал чтобы мой айпод открывал их а то щяс всё обновлено просит выше ios.

    • Руслан, к сожалению для iPod touch 4G топовая прошивка – 6.1.6

  19. Как быть подарили айфон 4 хочу поставить вибер но пишет что необходима ios 8, но до этой версии он не обновляет, а у предыдущего владельца вибер на этом телефоне был?

    • И мне подскажите что делать в этой ситуации?

  20. Андрей

    Не могу установить вайбер на айфон 4 7.1.2. Хочет 8. Что делать помогите!!!!!!

    • Виталий

      Та же проблема ни вайбер ни инстаграм ничего толком не установиш

  21. Виталий

    Здравствуйте, у меня iPhone 4 версия прошивки 7.1.2 а в тех приложениях которые я хочу установить требует минимум 8.0 что с этим делать можно ли установить более позднюю версию приложения если да то как? Заранее спасибо

  22. Здравствуйте, у меня iPhone 4 версия прошивки 7.1.2, а в тех приложениях которые я хочу установить требует минимум 8.0, что с этим делать можно ли установить более позднюю версию приложения если да, то как? Заранее спасибо.

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *

*